USER PANEL



Login:
Password:

MOST ACTIVE USERS

Lu
Total comments: 14392
adzhoe
Total comments: 14022
salsapopo
Total comments: 12713
mahedi
Total comments: 10688
2fuzzy
Total comments: 10400
Jinxaruny
Total comments: 10324
raymond.wendt
Total comments: 9110
Louie
Total comments: 8134
Ty Webb
Total comments: 6156
DocMcCoy
Total comments: 6039

SEARCH 

When Drag Racing Gone Totally Wrong

Video | 26 Dec, 2012 | Views: 4279 |  +26   |  
Loading the player ...

Do you like it?



Email this link


It is just one of the thousands of posts that we have on the Acidcow.com.
Please visit our main page to see other great pictures and videos!


№1 Author: Nick1090 (27 Dec 2012 03:35) Total user comments: 417


Activity rewards:
0
Doh!!
№2 Author: rusboris (27 Dec 2012 03:54) Total user comments: 458


Activity rewards:
+7
This player sucks. Am I the only one who it takes forever to load even this 9 second clip? And it won't even let you easily pause to let it buffer
№3 Author: Bruce Burbank (27 Dec 2012 06:39) Total user comments: 202


Activity rewards:
+7
You're not the only one, rusboris. The new video players suck for me too.
№4 Author: anakin fartwalker (27 Dec 2012 08:27) Total user comments: 368


Activity rewards:
0
white civic driver must be unlucky brian
№5 Author: adzhoe (27 Dec 2012 08:51) Total user comments: 14022


Activity rewards:
0
Send him home
№6 Author: jP (27 Dec 2012 14:58) Total user comments: 835


Activity rewards:
-1
Why dragrace with a Honda!?

They belong in the scrapyard....

RICERS!
№7 Author: mahedi (27 Dec 2012 18:12) Total user comments: 10688


Activity rewards:
0
Shit 13
№8 Author: ARMac (28 Dec 2012 00:34) Total user comments: 112


Activity rewards:
0
I think its the server load. I also had problems with the old player on specific time of the day.

This morning all clips loaded instantly, now all clips lag.
Your name: